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About the Vicon CaraPost User Guide

Read this guide for basic information that enables you to start using 
Vicon CaraPost. The guide begins by explaining how to install and license 
CaraPost. It then explains a basic workflow, from importing capture files (.pico) 
and a calibration file (.xcp), through initialization and tracking to common 
clean-up tasks and export.

Videos that accompany this guide are available from Vicon Support. The videos 
include the following topics:

❙ Introduction and basic overview 

❙ Blob detection 

❙ Creating and using sticks and labels 

❙ Initialization 

❙ Tracking 

❙ Optimization 

❙ Data export 

For more detailed and advanced information, see the Vicon CaraPost Reference 
Guide.
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About Vicon Cara documentation
The following documentation (online help and PDFs) is included in the 
Vicon Cara release:

The PDFs (for Adobe Reader version 8.0 or later) are installed as part of your 
Vicon Cara software installation. 

The documents available to you depend upon your Vicon software license 
options. 

You can also obtain these, and other Vicon documents, from the Downloads 
page of the Vicon Support website.

Document Description

Vicon Cara User Guide Provides system description, installation 
instructions (in PDF only) and licensing 
instructions, and a basic step-by-step workflow.

PDF and online help installed with CaraLive. 

Vicon Cara Reference Contains details of advanced functionality, 
information about the configuration server, 
descriptions of settings and options, and 
supported file formats. Hardware details and a 
glossary are also included.

PDF and online help installed with CaraLive.

Vicon CaraPost User Guide Provides system description, installation 
instructions (in PDF only) and licensing 
instructions, and a basic step-by-step workflow.

PDF and online help installed with CaraPost. 

Vicon CaraPost Reference Contains details of advanced functionality, 
descriptions of settings and options, and 
supported file formats. A glossary is also 
included.

PDF and online help installed with CaraPost.
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Prepare to use Vicon CaraPost

Before using Vicon CaraPost for the first time, ensure that your equipment 
meets the minimum requirements and that you understand the file types with 
which you will work. For more information, see the following topics:

❙ Vicon CaraPost requirements

❙ About Vicon CaraLive output files
Vicon Motion Systems January 2015 Page 5 of 84
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Vicon CaraPost requirements
The following specifications for a PC for use with Vicon CaraPost is given as an 
approximate guide only. Ensure that your system meets these requirements:

❙ Quad core 3+GHz processor

❙ 16 GB Memory

❙ 500 GB hard drive

❙ NVidia Quadro K4000 or equivalent graphics card

❙ Windows 7 Professional 64-bit

For information about requirements for using Vicon CaraLive, see Using Vicon 
Cara.
Page 6 of 84 January 2015 Vicon Motion Systems
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About Vicon CaraLive output files
To work with Vicon CaraPost, you need to import capture files (*.pico) and the 
related calibration files (*.xcp). 

Takes (.pico files) are captured with Vicon CaraLive; calibration files (.xcp) are 
also created using CaraLive, but may be saved with CaraPost. For information 
on creating calibration files, see the Vicon Cara User Guide.

Tip
Example capture files and calibration files are available for download on the Vicon 
Support website: this document assumes that you are working with these files. If you 
prefer, you may substitute your own .pico and .xcp files, but you may then need to use 
different blob detection settings from those described, and perform additional manual 
processing.
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Install and license Vicon CaraPost

This chapter covers the following topics:

❙ Install Vicon software

❙ License Vicon CaraPost: 

❙ Request a license

❙ Activate a license

❙ Set the license server

❙ Move and revoke licenses 

❙ View information about license servers
Vicon Motion Systems January 2015 Page 9 of 84
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Install Vicon software

To install Vicon CaraPost:

1. Log on to Vicon Online Support at http://www.vicon.com/support/, using 
the Vicon Online Support logon that was provided when you bought 
CaraPost.  

2. Visit the Animation section of the Downloads page and download the 
CaraPost 1.1 software installer.

3. In Windows Explorer, go to the folder to which you downloaded the installer 
and double-click Vicon_CaraPost_Setup.exe. 

4. On each wizard page, provide the requested details, and click Next.

5. On the End-User License Agreement wizard page, read and accept the 
terms.

     Tip
If you choose to install the license server, if an older version of the license server is 
already installed, it is replaced. If the same version is already installed, the license 
server is not installed. If you are already using any other version of the SafeNet 
licensing tools, before replacing them with the version included with CaraPost, 
contact Vicon Support for advice.

If you are setting up a network license server and you do not want CaraPost on that 
machine, you can choose to install only the license sever.

6. In the confirmation boxes, check that the selected components have been 
successfully installed and click OK.

7. On the final wizard page, click Finish.

8. Enter the required information into the subsequent dialog boxes until the 
installation is complete.

Note
Installing the Sentinel License Manager also installs the License Tools.
Page 10 of 84 January 2015 Vicon Motion Systems
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License Vicon CaraPost
To start using CaraPost, you must first request a license and activate it. You may 
also need to set the license server for your license. If you want to use CaraPost 
remotely, you will need to set up commuter licensing. For details of these 
procedures, see the following topics:

❙ Request a license 

❙ Activate a license 

❙ Set the license server 

❙ Move and revoke licenses 

The Vicon Licensing software also enables you to:

❙ View information about license servers 

Request a license
To request a license, you start Vicon CaraPost and supply the relevant details.

To request a license from Vicon Support:

1. If you are using a SafeNet dongle to license your machine:

a. Ensure you have installed the latest drivers for the dongle onto the PC 
on which you will run CaraPost. You can either choose the option for 
dongle drivers when you install CaraPost, or run the CaraPost installer 
at any time, or you can download the drivers from the Vicon Support 
website.

b. Insert the dongle.

2. On the machine for which you want the license (either a networked license 
server or a standalone machine), start CaraPost and at the left of the dialog 
box, click Request License.

     Tip
You can also manage licensing in the following ways:
– After you have licensed Vicon CaraPost, start CaraPost and on the Help 
menu, click Licensing ; or
– To run the Vicon Automated Unified Licensing Tool (VAULT) 
independently of CaraPost, click the Start button, then All Programs > Vicon 
> Licensing > Product Licensing.
Vicon Motion Systems January 2015 Page 11 of 84
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3. At the top of the Request a License dialog box, from the Product and 
Product Version menus, ensure CaraPost and 1.x are selected.

4. In the appropriate fields, type your name, email address and company name. 

5. In the Options area, select whether to request:

❙ Standalone license locked to local PC name: for use by the PC from 
which you are sending this request only

❙ Network license locked to license server name: for use on the license 
server machine from which you are sending this request by one or more 
PCs on the same network

❙ Standalone license locked to a dongle: for use with the specified dongle 
on a single PC. In the Dongle ID field, type the ID, which is found on the 
dongle.

❙ Network license locked to a dongle: for use on a license server machine 
by one or more PCs via the specified dongle. In the Dongle ID field, type 
the ID, which is found on the dongle.

6. For network/server based licenses only: if necessary, change the value for 
the Number of Seats.

7. Leave the settings in the Machine area at their default values unless you are 
asked to change them by Vicon Support (for example, if you are using a dual-
booting system or have had to reinstall Windows).

8. Do one of the following:

❙ If you can currently email your license request, click the Email Request 
button; or

❙ If email is currently unavailable, click Save Request to a file, so that you 
can send the request later. Type or browse to a suitable location and 
click OK. The file is saved as ViconLicenseRequest*.xml. When possible, 
email the file to Vicon Support.
Page 12 of 84 January 2015 Vicon Motion Systems
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Activate a license
After you have received a license file from Vicon Support, you must activate it 
before you can start using Vicon CaraPost.

To activate a license:

1. Check your email for a message from Vicon Support. The license file (named 
CaraPost Release Number License Type.lic ) is attached to the email. If you 
are using a Safenet dongle, the email has the ID of your dongle (of the form 
UBnnnnnn) in the Subject line. 

If you have not received a license file, request one as described in Request 
a license on page 11.

2. Save the license file (*.lic) to the Windows desktop of the machine for which 
you have a license (or any other suitable location).

3. Start CaraPost and in the Vicon Automated Unified Licensing Tool dialog 
box, click Activate License.

4. Depending on whether you are using the file as it was received from Vicon 
Support or as a text string copied from the file:

❙ In the License File Activation field, type or browse to the location of the 
license file (*.lic) and click Activate from File; or

❙ Copy the text to the License Activation string field and click Activate 
from String.

5. Click OK.

Tip
You can only deactivate a network license from the relevant license server machine, not 
from any of the client machines.

Set the license server
If a server provides licenses to client PCs on your network, to enable a client PC 
to find its license quickly, on the client PC specify the license server for 
Vicon CaraPost to use. 
If you use standalone licensing, CaraPost should automatically find its license, 
but if not, or if you need to change the license server, complete the following 
steps.
Vicon Motion Systems January 2015 Page 13 of 84
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To enable CaraPost to find its license:

1. Ensure you have installed CaraPost as described in Install Vicon software on 
page 10. Depending on the type of license you have, ensure that your 
system is ready:

❙ If your PC obtains its license from a license server, ensure that CaraPost 
is licensed on the relevant server. 

❙ If you are using a standalone license, ensure that you have requested, 
saved and activated your license on this machine.

2. Start CaraPost and depending on whether or not a license is found:

❙ If the Vicon Automated Unified Licensing Tool dialog box opens, click 
Set License Server; or

❙ If CaraPost opens and you want to view or change the license server:

a. On the Help menu, click Licensing. 

b. In the Vicon Automated Unified Licensing Tool dialog box, go to the 
Product License Location list (in the lower half of the dialog box), 
and right-click on the line that shows the relevant CaraPost license 
and then click Set License Type.

3. In the Change License Server dialog box, do one of the following:

❙ To use standalone licensing, click Use Standalone/Commuter Licenses 
Only and then click OK.

❙ To obtain a license from any available license server (local or on a 
network), click Use Standalone/Commuter Licenses Or Scan for a 
License Server and then click OK.

❙ To select a specific license server from a list of all available servers:

a. Click Discover. Both local and network licenses are displayed.

b. In the Available Servers list, double-click the required license server 
and then click OK.

❙ To specify a license server on your network, click Use a Specific Network 
License Server, type the name in the License Server field, and click OK.

Tip
You can instead select the required license server by going to the License Server list (in 
the upper half of the dialog box), right-clicking on the line that shows the relevant 
CaraPost license and then clicking Use This License for Cara.
Page 14 of 84 January 2015 Vicon Motion Systems
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Move and revoke licenses
You can check out (borrow) a seat from a network license so that it can be used 
for the number of days that you specify, on a machine that is not connected to 
the license server network. You can check out a seat to either:

❙ A machine on your network (see Check out to a network machine below), 
so that Vicon CaraPost can subsequently be used when the machine is no 
longer connected to your network; or 

❙ A machine that is not connected to your network (see Check out to a remote 
machine below)

When a commuter license is no longer needed, it is checked back in again, so 
that it can be used from the license server network as usual. Licenses are 
automatically checked in at the end of a specified check-out period, or can be 
manually checked in early (not applicable to remotely checked-out licenses), 
For more information, see Check in a commuter license on page 18.

Check out to a network machine
You can check out a seat from an existing license for use on a machine on your 
license server network, so that Vicon CaraPost can subsequently be used on the 
machine when it is no longer connected to your network.

To check out a seat to a machine on the license server network:

1. On a network machine that you later want to use remotely, open the 
advanced Vicon Automated Unified Licensing Tool dialog box by doing one 
of the following:

❙ Start CaraPost and on the Help menu, click Licensing; or

❙ Click the Start button, then All Programs > Vicon > Licensing > 
Product Licensing.

2. In the License Server list in the top part of the dialog box, right-click on the 
license that contains the seat that you want to check out and click Check 
Out.

3. In the Check Out License dialog box, specify the number of days for the 
license to be used remotely and then click Check Out. 

Checked out licenses are flagged with Commuter in the Type column in the 
License Server list in the top part of the Vicon Automated Unified Licensing 
Tool dialog box.
Vicon Motion Systems January 2015 Page 15 of 84
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Check out to a remote machine
In addition to checking out a license to a network machine (see Check out to 
a network machine above), you can also check out a license to a machine that 
is running the Vicon Automated Unified Licensing Tool (VAULT), but is not 
connected to the network containing the license server. This involves the 
following procedures:

❙ On the remote machine: Generate a locking code and send it to a user of a 
machine on the license server network.

❙ On a network machine: Check out a commuter license and send it to the 
remote user.

❙ On the remote machine: Save and activate the commuter license 

On the remote machine: Generate a locking code

1. To open the advanced Vicon Automated Unified Licensing Tool dialog box, 
do one of the following:

❙ Start Vicon CaraPost and in the Vicon Automated Unified Licensing 
Tool dialog box click Advanced Licensing; or

❙ Click the Start button, then All Programs > Vicon > Licensing > 
Product Licensing.

2. In the Vicon Automated Unified Licensing Tool dialog box, click View 
Remote Locking Code.

3. In the Current Machine Locking Code dialog box, type the email address of 
a person to whom the network license server is available, and click Send, or 
to save it to a string to send later, type or browse to the required location 
and filename, click Save to File and close the dialog box.

The person with access to the license server can then check out a 
commuter license for use on the remote machine, as described in the 
following steps.
Page 16 of 84 January 2015 Vicon Motion Systems
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On a network machine: Check out a commuter license

1. To open the advanced Vicon Automated Unified Licensing Tool dialog box, 
do one of the following:

❙ Start CaraPost and on the Help menu, click Licensing; or

❙ Click the Start button, then All Programs > Vicon > Licensing > 
Product Licensing.

2. In the License Server list in the top part of the dialog box, right-click on a 
license that permits commuter licensing for CaraPost.

If the selected license permits commuter licensing, the context menu 
displays a Check Out option and at the bottom of the dialog box, a Check 
Out button is displayed.

3. Click Check Out and in the Check Out License dialog box:

a. Specify the number of days for which you want to use the license 
remotely.

b. Expand the Advanced Options by clicking the downward pointing arrow 
on the right, and click Remote Check Out.

     Caution
Do not overestimate the number of days for which the license will remain checked 
out. After a remote check out, you cannot check the license back in again until the 
number of days that you specified has expired.

4. |n the Remote Commuter License Check Out dialog box, enter the locking 
code string for the remote machine that was emailed or sent by the user of 
the remote machine, as described in On the remote machine: Generate a 
locking code above, and click Check Out.

5. In the Save Commuter License dialog box, type or browse to a path and 
filename for the saved commuter license, click Save to File and then close 
the dialog box. The commuter license is saved as a license file (*.lic).

6. Email the saved commuter license file to the remote user.

The remote user can then save and activate the checked-out commuter 
license on the remote machine, as described in the following steps.
Vicon Motion Systems January 2015 Page 17 of 84
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On the remote machine: Save and activate the commuter license

1. Save the file that was sent to you as described in On a network machine: 
Check out a commuter license above to the Windows desktop (or any other 
suitable location). 

2. To open the advanced Vicon Automated Unified Licensing Tool dialog box, 
do one of the following:

❙ Start Vicon CaraPost and in the Vicon Automated Unified Licensing 
Tool dialog box click Activate License; or

❙ Click the Start button, then All Programs > Vicon > Licensing > 
Product Licensing, and then click Activate License. 

3. Depending on whether you are using the file as it was received from the 
license network user or a text string copied from the file, do one of the 
following:

❙ In the License File Activation field, type or browse to the location of the 
license file (*.lic) and click Activate from File; or

❙ Copy the text to the License Activation string field and click Activate 
from String.

4. Close the Activate a License dialog box.

In the License Server list in the top part of the Vicon Automated Unified 
Licensing Tool dialog box, checked out licenses are flagged with Commuter 
in the Type column.

Check in a commuter license
Licenses that have been checked out are checked back in and made available 
for use from the network in either of the following ways:

❙ If the specified check-out period has expired, the license is automatically 
checked back in.

❙ If the license is no longer needed for remote use, you can check it back in 
early. 

     Caution
This does not apply to licenses that were checked out using Remote Check Out, 
which remain checked out until their check-out period expires.
Page 18 of 84 January 2015 Vicon Motion Systems
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To check in a license manually:

1. To open the advanced Vicon Automated Unified Licensing Tool dialog box, 
do one of the following:

❙ Start Vicon CaraPost and on the Help menu, click Licensing.; or

❙ Click the Start button, then All Programs > Vicon > Licensing > 
Product Licensing.

2. In the top part of the Vicon Automated Unified Licensing Tool dialog box, 
click on the license you want to check in and then click Check In License.

Important
You cannot check in a license that was checked out using Remote Check Out before its 
check-out period has expired. You set the check-out period when you check out a 
license. To see how many days are left on a commuter license, in the License Server list 
in the top part of the Vicon Automated Unified Licensing Tool dialog box, find the 
relevant license and look at the date in the Expiry column.

Revoke a license
You may find that you need to move your Vicon CaraLive license to a license 
server machine that is different from the one for which you originally obtained 
the license. To do this, you must revoke the original license. (If you want to 
temporarily use a single license seat on a remote machine, see Move and revoke 
licenses on page 15.)

Important
To avoid delays when changing license servers, before clicking Revoke License, email 
Vicon Support and wait to receive a reply before proceeding.

Ensure that your email to Vicon Support includes the following details:

❙ The Vicon product name (ie Vicon CaraLive) and license revocation in the 
Subject line of the email.

❙ Information about the license that you want to revoke, including number of 
seats and locking code of the license server machine.

❙ The locking code of the machine to which you want to move the license.
Vicon Motion Systems January 2015 Page 19 of 84
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View information about license servers
In the Vicon Automated Unified Licensing Tool dialog box, you can view 
information about all available license servers without affecting the license 
server that is currently in use. To do this:
1. Open the advanced Vicon Automated Unified Licensing Tool dialog box by 

doing one of the following: 

❙ Before licensing Vicon CaraPost, start CaraPost and in the Vicon 
Automated Unified Licensing Tool dialog box click Advanced Licensing; 
or

❙ After CaraPost is licensed, start CaraPost and on the Help menu, click 
Licensing to open the Vicon Automated Unified Licensing Tool dialog 
box; or

❙ Click the Windows Start button, then All Programs > Vicon > Licensing 
> Product Licensing.

2. In the Vicon Automated Unified Licensing Tool dialog box, if the required 
license server is not displayed in the License Server field at the top, click 
Change at the top right of the dialog box.

3. In the Options area of the Select License Server dialog box, do one of the 
following:

❙ To view local standalone licenses and commuter licenses, select View 
Licenses from the Locally Installed License Server; or

❙ To view licenses on a specified license server, type the name of the 
required server in the License Server field. If you do not know the name 
of the license server, click Discover and in the Available Servers list, 
double-click a license server. 

4. Click OK. 

In License Server list in the top part of the Vicon Automated Unified 
Licensing Tool dialog box, licenses from the specified license server are 
displayed.

Tip
Changing the license server that is displayed in the License Server list does not affect 
the license server that is used for licensing, shown in the Product License Location list 
in the lower part of the dialog box. To change the license server that is used for licensing, 
see Set the license server on page 13.
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Initialize and track a take

Vicon CaraPost enables you to process captures made using Vicon CaraLive.

The following topics describe the workflows for initializing and tracking a take 
using CaraPost. Two basic workflows are described: 

❙ Initializing and tracking a take completely from scratch; and 

❙ Using a frame from an existing processed take to provide an efficient way 
of initializing subsequent takes for the same actor and marker set (Initialize 
from ROM).

The first workflow is explained using a Range of Motion (ROM) take (called 
ROM) as an example, which is then used in the second workflow to initialize and 
track a subsequent take called The Greatest. All example data is available for 
download on the Vicon Support website, in the same location as the CaraPost 
installer.

To perform the Initialize from ROM workflow, you need to have processed 
(initialized) only a single frame in the ROM take; this gives the most efficient 
workflow. However, in some situations, processing the whole ROM take gives 
more flexibility for initializing subsequent takes, for example, if the actor cannot 
start from the ROM pose in each subsequent take. It is this slightly more general 
processing workflow that is described in this chapter, which includes the 
following topics.

❙ Start Vicon CaraPost

❙ Import capture files

❙ Set blob parameters

❙ Detect blobs

❙ Initialize the calibration brim
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❙ Initialize face marker positions

❙ Manually connect data

❙ Label face markers

❙ Create a mesh

❙ Track the rest of the take

❙ Save the completed take

When you have completed these steps, you can perform any clean up required 
as described in Optimize a take on page 53. 

You can then use a single frame from the resulting clean ROM file to initialize 
subsequent takes. For more information, see Initialize from a ROM file on 
page 49. 

About the example files
To enable you to use to get accustomed to using Vicon CaraPost, the following 
sample files are supplied on the Vicon Support website, in the same location as 
the CaraPost installer.

❙ ROM_0.pico, ROM_1.pico, ROM_2.pico, ROM_3.pico 

❙ Calibration.xcp 

❙ TheGreatest_0.pico, TheGreatest_1.pico, TheGreatest_2.pico, 
TheGreatest_3.pico (short monologue from the film The Greatest)

❙ MarkerList.txt (sample list of marker names)

Start Vicon CaraPost

To start Vicon CaraPost:

1. On the Windows desktop, double-click the Vicon CaraPost shortcut:

The Vicon CaraPost window is displayed.
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Import capture files
After you have started Vicon CaraPost, the first step in processing a take is to 
import the capture files (*.pico), and the calibration file (*.xcp) that you want to 
work with. 

Takes are captured with Vicon CaraLive; calibration files are created using 
CaraLive, but can also be saved from CaraPost. For information on creating 
takes and calibration files, see the Vicon Cara User Guide.

Important
You can download example capture files and calibration files from the Vicon Support 
website, in the same location as the CaraPost installer. The following instructions 
assume that you are working with these files. If you prefer, you may substitute your own 
.pico and .xcp files, but you may then need to use different blob detection settings. 

The following example ROM file and accompanying calibration file is available 
on the Vicon Support website, in the same location as the CaraPost installer:

❙ ROM-0.pico, ROM-01.pico, ROM-02.pico, ROM-3.pico 

❙ Calibration.xcp 

To import and prepare a take for processing:

1. On the File menu, click Import Pico Files, browse to the folder containing the 
downloaded sample data, then in the dialog box, select the take named 
ROM.

When the file has opened, click one of the buttons at the top left of the 
CaraPost window that enables you to view all four camera views:

2. To re-orientate the camera views (channels) that appear upside-down:

a. To select a view, Shift+click on it. 

The Channel title at the top of the selected camera view turns green, to 
indicate you selected it. 

b. To select more than one view, keep the Shift key pressed down and click 
any other views that you need to rotate.

c. To rotate a camera view, press CTRL+right arrow twice.
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When you have finished, click in a view to deselect the selected views. 
The Channel titles turn yellow again. Ensure that you deselect all the 
views.

3. On the File menu, click Import XCP and from the folder containing the 
downloaded sample data, select Calibration.xcp. 

The Log displays a line item Import XCP (file path and name) succeeded. In 
the Selection window, a Global item appears at the bottom of the list. 

     Tip
If the Selection window or any other window that you want to display is not currently 
visible, right-click on the menu bar of one of the visible windows and click the 
required window name. To dock and undock windows, double-click them.

The .xcp file contains the Field of View (FOV) and radial distortion values for the 
cameras used during the Vicon CaraLive capture. Vicon CaraPost needs this 
information to reconstruct the 3D points correctly.

Set blob parameters
The blob detection settings are saved in the take that is captured with 
Vicon CaraLive. However, if the blob detection settings are not as required, you 
can change them, as described in Preview and adjust blob parameters below.

When setting the blob parameters, aim to adjust them so that the following 
markers are detected throughout the take.

Note
If you were just processing only a single frame in the ROM take, you would need to ensure 
that the blob parameters produce good results on the single frame only.

❙ Markers on the same side of the face as the camera

❙ Markers down the middle of the face

❙ ALL the calibration brim markers

If you have a few face markers in shadow or that have low contrast with the 
background because they’re on or near the lips, etc, you can safely ignore them.

For detailed information on blob parameters, see Blob Parameters section in the 
Vicon CaraPost Reference.
Page 24 of 84 January 2015 Vicon Motion Systems
52



CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexInitialize
& track
Preview and adjust blob parameters
After you have imported the capture files, you can preview and adjust the blob 
parameters. When you have set them to optimize blob detection throughout the 
whole take, you can run the Vicon CaraPost blob detection process.

To adjust blob detection settings:

1. To preview blob detection, right-click on a camera view and select Blob 
Preview. 

This displays the blobs that would be detected with the current Blob 
Parameters settings if you were to run the Detect Blobs process. With the 
default settings used on the ROM files, views similar to the following are 
displayed:

     Tip
The blob detection results are likely to contain noise (additional, unwanted 
detections). Noise increases the chances of Vicon CaraPost making incorrect 
correspondences between the 2D and 3D data. If, to try to correct this, you make the 
blob parameters too strict, some markers may not be detected or may not be 
detected throughout the take. Although obtaining optimum detections is a balance 
between having too much noise or too few detections, it is better to detect as many 
of the brim blobs and face blobs as possible, even if this results in additional 
unwanted detections.
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2. Go to the first frame that you want to track. This will normally be the first 
frame in the take, unless you are using a clapperboard, in which case, go to 
the first frame after the clapperboard is used. If you are processing a single 
ROM frame only, select a frame that contains a neutral face pose.

3. In the Blob Parameters section of the Properties pane, select the required 
blob type(s), ensuring that you select the color(s) required for both brim 
blobs and face blobs. If you are detecting blobs of one color only, clear the 
check boxes for the blobs of the unused color. This enables the system to 
work faster.

For the ROM take, white markers are used on both the brim and the face, 
so select Find White Blobs and ensure Find Black Blobs is cleared.

     Tip
Vicon Cara supports white and black blobs, so you can choose the type that suits 
your capture requirements. White markers normally offer the best level of contrast, 
especially when used in combination with on-board lighting. Both white and black 
versions of the brim and calibration grid are supplied in the Vicon Cara kit

4. For the ROM take from the sample data, adjust the remaining settings as 
follows: 

❙ White Min Radius to 3

❙ White Max Radius to 15

❙ White Threshold to 0.5

If you are not using the ROM take from the sample data and some blobs 
aren’t visible:

a. Decrease the Threshold(s) in decrements of 0.05 until all the blobs you 
need are detected. If additional, unwanted blobs are also detected, 
remember that you can easily delete these later if they cause a problem 
with the tracking. 

b. Adjust the Min Radius and Max Radius settings so they are as large and 
small respectively to fit all the blobs that you need. 

The Blob Parameters section should now look similar to this, although the 
values may vary if you are not using the ROM take:
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     Tip
To see the results of your changes, press Enter or click outside the text box.

5. Scrub through the take to make sure the blob detections are good for all 
frames, ideally with as little noise as possible.

Although there may be a few unwanted detections and/or some blobs that 
are not detected in all frames, the take should now be ready for you to run 
the blob detection process.

Detect blobs
After you have previewed and adjusted the blob parameters, you can run the 
blob detection process on the required frame(s) in the take you have imported. 

In the following steps, the blob detection process is run on the whole of the 
example ROM take. If you want to detect blobs in only a single frame, or a limited 
range of frames, use Detect Blobs [Current Frame], or select a range of frames 
before running the Detect Blobs [Active Range] command. To select a range of 
frames, go to the first frame of the required range and press CTRL+1. Go to the 
last frame of the required range and press CTRL+2.

Tip
If you detect blobs for only a single frame or a limited range of frames, when you track 
the take, blob detection is automatically run on the whole take as well.

If you are likely to need to perform tracking more than once (for example, to try re-
tracking with different parameters), you may find it quicker to ensure blob detection and 
tracking are run separately. To do this, ensure you blob detect the entire take before you 
track it.
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To detect blobs for the whole take:

1. Scrub to the first frame (or press the Home key) of the ROM file.

2. To give a clear view of detections, turn off blob detection previews by right-
clicking on a camera view and clearing Blob Preview. 

3. On the Process menu, click Detect Blobs [Active Range].

The blob detection process runs on the whole take. The detected blobs are 
displayed in red. The first frame should look similar to the following example:

Note that some unwanted blobs (red detections where there are no 
markers) will probably be detected. These may result in mismatched blobs 
during the Initialize 3D process. 

4. To delete any unwanted detections, box-select (click+drag) or lasso-select 
(ALT+SHIFT+click+drag) them, then on the Edit menu, click Delete Selected 
or press CTRL+D. The result should look similar to the following example:
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Initialize the calibration brim
After you have imported the relevant capture files and blob-detected the take, 
the next step is to enable CaraPost to initialize the calibration brim that was 
used on the first frame of the take. The calibration brim is a known pattern of 
markers that is used to calculate the positions of the cameras. 

To initialize the calibration brim:

1. On the Process menu, click Initialize Default Calibration Brim [V2.0]. 

     Note
If you are using a custom brim, you may need to use a different option.

In the History pane, Initialize Default Calibration Brim is displayed.

2. On the View menu, click New Floating Workspace.

The calibration brim appears in a 3D view. 

     Tip
To zoom out so you can see the whole calibration brim, in the new workspace, press 
SHIFT+right-click+drag down. 

3. Click on the leftmost calibration brim marker in the first camera view so that 
it turns green. Then CTRL+click the same marker in the other three camera 
views and in the 3D view so they are all selected:
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4. On the Edit menu, click Merge (or press M).

A correspondence between the blob detections and the 3D model of the 
calibration brim is created. 

5. Repeat the previous 2 steps to create correspondences for at least four 
points on the calibration brim in all camera views. The following example 
shows correspondences for five calibration brim points (displayed in green):

6. To enable Vicon CaraPost to calculate the approximate positions of the 
cameras, on the Process menu, click Solve Calibration Brim [Manual].

The 3D view should look similar to this: 

The light blue points are not required, so select and delete them (press 
CTRL+D). 
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If necessary, use the following commands to adjust the view:

7. To examine the 2D re-projection errors, in a camera view, SHIFT+right-
click+drag on a marker in the calibration brim (to keep the marker in the 
center of the view, you may also need to use SHIFT+left & right (or middle) 
button+drag). 

The view zooms in, so that you can clearly see the 2D and 3D data (slightly 
enlarged in the following example):

Action Mouse and keyboard combination

Zoom ALT+right-click+drag or SHIFT+right-click+drag 

Pan ALT+click+drag or SHIFT+click+drag 

Dolly ALT+left & right (or middle) button+drag or 
SHIFT+left & right (or middle) button+drag
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The red cross is the center point of the 2D detection, the blue cross is the 
center point of the 3D projection and the small yellow line connecting the 
two is the error. 

In the above example the yellow line is short and when we look at the other 
detections in the same example, the blue crosses all appear over the 
detections, which indicates that the calibration brim is correctly aligned, as 
shown in the following image:

If the yellow lines representing the 2D re-projection errors are long (ie, more 
than a few pixels in length), this indicates that the calibration brim is not 
correctly aligned. The probable cause of this is that one or more brim points 
are mismatched in one or more of the camera views. Before continuing to 
the next processing step, correct any mismatches and obtain a good brim 
alignment. 
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Initialize face marker positions
When the calibration brim is correctly aligned and Vicon CaraPost has 
approximately calculated the camera positions, you must supply additional 
information to enable CaraPost to initialize the facial point data. This also 
enables CaraPost to calculate more accurate camera positions. You do this by 
matching additional seed points on the face, which are then used as a starting 
point to initialize the rest of the facial points. 

The aim of this processing step is to correctly initialize the positions of all the 
face markers that you are interested in tracking through the take, and to ensure 
that there are matched detections in all the camera views in which they are 
visible.

Selecting additional seed points is similar to merging the calibration brim points 
except that you don't need to click in the 3D view (because unlike the brim, the 
3D structure of the facial points is not yet known). 

For the seed points, choose four or five points that are both:

❙ Spread over the face

❙ Near other detections

Typically, choose the following points:

Tip
Four or five points are adequate for a simple take, but a more complex take with a more 
sophisticated marker set may require more seed points. For information on selecting and 
using seed points for a (dense) 156 marker set and other marker sets, see 3D initialization 
for alternative marker sets in the Vicon CaraPost Reference Guide.

Position Number of points Minimum number of camera 
views in which points are visible

Forehead 1 4

Chin and/or lips 1 per position 4

Cheek 1 on each 2 or more

Nose 1 4
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To add seed points:

1. CTRL+click on the chosen marker in each camera view in which it is visible. 

2. Press M to merge the detections.

When you press M, a yellow point should appear in the 2D view and also in 
the 3D view.

Repeat for all the points you want to use. For the ROM example provided, 
the result should look similar to the following image:

3. If you are working with the ROM take, zoom in to the nose marker in any 
camera view, and notice that it has a fairly large error line. 

4. To use the additional seed points to further refine the camera positions and 
improve the accuracy of the points, on the Process menu, click Bundle 
Current Frame [Unconstrained]. 

The nose point now has almost no error line.
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5. In the Properties pane, ensure that the Initialize 3D Parameters are set to 
the following (default) values:

❙ Max. Allowed Depth: 35.0

❙ Max. 3D Distance To Merge: 5.0

❙ Max. Allowed Symmetric Epipolar Distance: 5.0

For alternate marker sets, you may need to adjust these parameter values 
(see 3D initialization for alternative marker sets in the Vicon CaraPost 
Reference Guide).

6. From the information you have supplied, you can now enable 
Vicon CaraPost to reconstruct all the other markers. To do this, on the 
Process menu, click Initialize 3D. The result should look similar to the 
following image:

Review the results of the initialization in detail across the four camera views, 
and also in a 3D view. Look out for:

❙ Mismatched detections. These appear as 3D points that are not aligned 
with the rest of the face points. See the examples in Manually connect data 
on page 36.

❙ Undetected face markers that you want to track. See the examples in 
Manually connect data on page 36.

If you find mismatched points or connections that were missed by the 
automatic process, you will need to manually correct them. For information on 
how to do this, see the next section. 
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Manually connect data 
When you have reconstructed the markers, notice that there are both yellow 
and orange projections. The significance of these colors is:

❙ Yellow projections Have an associated detection in that camera view

❙ Orange points Do not have an associated detection in that camera view

You can merge some of these points to use all the available data. However, you 
should normally ignore partially obscured or very elliptical detections on the far 
side of the face as they may not track very well and can cause noisy 3D data. 

You may need to merge the points manually in the following situations:

❙ When Vicon CaraPost has not connected an orange projection to a red 
detection, as shown in the following example from channel 1, frame 0 of the 
ROM take:

To fix this:

a. Drag-select both the red detection and the orange projection:

b. Press M.
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The orange (disconnected) marker goes yellow, and the red detection 
becomes blue, indicating that the detection is now connected to a 3D 
marker point.

❙ When both an orange (unconnected) point and a yellow (connected) 
projection is displayed, as shown in the following example:

This happens when the same marker has been paired twice instead of in all 
available camera views or when an incorrect detection has been associated 
with a point on the face. 

To fix an example of incorrect detection:

a. In channel 3, select the detection under the left nostril.

b. On the Edit menu, click Detach Detections [Current Frame] (or press 
CTRL+H).

The detection is removed from channel 3.

c. In channel 3, drag+select the correct upper left lip marker and press M 
to merge the correct detection.

d. Repeat this process for the same marker in channels 3 and 2.
Vicon Motion Systems January 2015 Page 37 of 84



CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexInitialize
& track
❙ When the marker detections in different camera views haven't been 
connected by the Initialize 3D process, as shown in the following example 
from channel 1 in the ROM example:

To fix this, select the relevant marker detections in channel 0 and 1 of the 
ROM take by CTRL+clicking the unmatched detections, and then press M.

❙ When unwanted detections are found on features on the face, as shown in 
the following example:

To delete the bad detection on the left eye, select the detection and on the 
Edit menu, click Delete Selected or press CTRL+D.
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When you have finished adding extra information, you must refine the camera 
positions and reconstructions.

To refine the camera positions and reconstructions:

 On the Process menu click Bundle Current Frame [Unconstrained].
To check the quality of the reconstructions, look at the yellow error lines and 
also look again in the 3D view for erroneous reconstructions. If you are 
working with the ROM take, your final initialized file will look similar to this:

After you have finished initialization, you may find it helpful to label the markers, 
to enable you to identify them more easily and/or to create a mesh, to help you 
spot tracking errors. For information on these additional steps, see: 

❙ Label face markers

❙ Create a mesh
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Label face markers
To make it easier to identify points, you can give your face markers more 
recognizable labels than the default names. These marker labels will be carried 
throughout all your data and into your 3D package. You can label markers in 
either of the following ways, or use a combination of both methods:

❙ Import marker labels

❙ Rename marker labels

Import marker labels
An example list of marker names is supplied with Vicon CaraPost, but you can 
use your own list of marker names as required. The names can to be in a simple 
text file (.txt) separated with spaces and/or carriage returns, or in an existing 
.cara file. 

For more information about the .txt file format for marker labels, see the 
Vicon CaraPost Reference Guide.

Example file supplied:

❙ MarkerList.txt 
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To import marker names and label the markers:

1. On the File menu, click Import Labels From Cara File or Import Labels From 
Text File and import the required file.

The list of marker names appears in the Labelling pane.

     Tip
If you can’t see the Labelling pane, right-click on the menu bar of one of the visible 
panes and click Labelling.

2. To label a marker, select a point in a camera view or 3D view then click on 
the marker name in the Labelling pane and press M. 

The name is now associated with that point. When you come to the Initialize 
from ROM processing step, the marker names are maintained across 
subsequent takes. 
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3. If you want to change the way the marker names are displayed, edit their 
properties in the Display section of the Properties pane:

Rename marker labels
In addition to importing a file containing marker names and assigning them to 
the markers, you can also rename marker labels.

To rename marker labels:

1. In a camera view, 3D view (View > New Floating Workspace), or in a 
Continuity graph, click on the point to rename and then press Ctrl+R (or Edit 
> Rename Point). 

2. In the Rename Point dialog box, enter a new name.

The new label name appears in the view.

     Tip
To view all custom labels, right-click in the view and then click Point Labels: All. 
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Create a mesh
You can make it easier to detect tracking errors by creating sticks between 
selected points, or creating sticks between all the points to form a mesh. 

Errors are easy to spot as irregularities or holes in the mesh.

Creating a mesh enables you to more easily see:

❙ If any points are missing in a particular frame, and 

❙ If any points have been incorrectly tracked or have swapped across the take.

Meshes can also be exported for use in other applications, eg, Vicon Blade.

To create and customize sticks:

1. In a 3D view (View > New Floating Workspace) or camera view, Ctrl+click 
two adjacent points between which you want to create a stick, and then 
press S (or on the Edit menu, click Create Stick from Selected Points). You 
can continue doing this until you have constructed a whole mesh. 

2. To change the color of the sticks, in a 3D view Ctrl+click or drag to select 
the required sticks and then click Edit > Change Stick Color.
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If you have customized the marker labels, the labels can be displayed on the 
mesh, as shown in the following example. (For information on creating 
custom marker labels, see Label face markers on page 40).
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To create a mesh of all points:

 If you want to automatically create a mesh of all the points, on the Edit 
menu, click Create Stick Mesh. 
The following example shows a mesh in the 2D views and the corresponding 
3D view.

Errors are easy to spot as irregularities or holes in the mesh. The following 
example shows that the selected point (displayed in green) has failed to track 
correctly between the first frame and the next, resulting in an obvious cross-
over of the sticks between the two frames.
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The following example shows a point missing from the nose:

Note
If you had decided to process only one frame of the ROM take, you could stop at this 
point, and save the take so that it could be used to initialize subsequent takes (see 
Initialize from a ROM file on page 49). 
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Track the rest of the take
When you have set up your camera positions and 3D reconstructions for the first 
frame, you can track the rest of the take. The default parameters, shown in the 
following example, should work well for most situations.

Tip
For information about each parameter, see Vicon CaraPost User Interface and Tracking 
parameters for alternative marker sets in the Vicon CaraPost Reference Guide.

To track the rest of the take:

1. To ensure you have not accidentally selected any points, click in the camera 
view in an area that contains no points. If you have one or more points 
selected before starting tracking, only the selected points will be tracked.

2. On the Process menu, click Track Forwards [Sequence].

Depending on the specification of your computer and the length of the take, 
processing may take some time. For example, the ROM files may take over 
a minute to track. 

     Tip
If you detected blobs for only a single frame or a limited range of frames, when you 
track the take, blob detection is automatically run on the whole take as well.
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3. To check the data quality:

a. Play the take, looking at the video and 3D views. Make sure the points 
are tracked across the whole take and check for noise in the 3D view, 
and in particular, any marker points which become mismatched or 
swapped during the tracking.

b. To help you find noisy data or gaps, right-click on a camera view 
(channel), point to View and then click a different view, such as Graph 
or Continuity. If you click on a point in a view, you can also use the 
Selected Points view to quickly spot any gaps in the data. To zoom in any 
of the views, SHIFT+right-click+drag.

The following Continuity chart shows two problem areas in the ROM take, 
shown by the orange and red sections. Orange represents where a single 
camera has tracked a point and red indicates that no cameras have tracked 
a point, thus creating a gap.

If you find that the take still contains mismatched points, noisy data, or points 
that drop in and out, you may want to perform some further manual clean up 
(see Optimize a take on page 53).

Before you proceed, it’s worth saving and exporting your cleaned take, if you 
haven’t done so already. 
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Save the completed take
After you have initialized and labeled a take, it is worth saving and exporting the 
cleaned up data.

To save a take: 

 On the File menu, click Save. If you are working with the supplied examples, 
the saved file will be referenced in Initialize from a ROM file below.

For information on exporting a take, see Export a take on page 73.

Initialize from a ROM file
When you have finished cleaning up a ROM file (see Optimize a take on page 53), 
to avoid having to repeat the manual 3D initialization and labeling process with 
subsequent takes, you can save the ROM take and then use one of its frames 
to initialize other takes. Marker labels and sticks are carried into the new take.

This section uses as examples the following supplied sample files:

❙ The Greatest. The performer was Leigh-Anne Gilbert and the monologue 
was taken from the film The Greatest.

❙ ROM_LabelledClean.cara 

Depending on how similar the subsequent takes are to the ROM take, you may 
be able to completely initialize the takes from the ROM take, or at least to 
initialize the calibration brim so that you can re-use the camera and brim data.

To initialize takes from a previously processed ROM take:

1. Save the cleaned ROM take as a .cara file (File > Save As).

2. Open or import the file(s) to which you want to apply the ROM take. You are 
likely to obtain the best results from files that share as many details as 
possible with the ROM file, for example:

❙ The position of the cameras in relation to the brim

❙ The position of the actor’s head in relation to the brim

❙ The marker set

❙ The actor
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To work with the supplied example files, on the File menu, click Import and 
from the sample data folder, select The Greatest. 

3. Ensure the take is open at the frame at which you want to apply the ROM. 
For the sample data, leave the take open at frame 0. 

4. On the Process menu, click Load ROM and select the .cara file that contains 
the labeled and cleaned up ROM take. In the supplied sample data, this is a 
file called ROM_LabelledClean.cara. 

5. To see the loaded ROM information, right-click on a camera view and ensure 
ROM is selected. The ROM information is shown in blue. In the following 
example, you can see the ROM markers in light blue. The positions are fairly 
close between the ROM take and the take to be initialized. 

6. Do one of the following:

❙ To use the data from the whole ROM (the face as well as the brim), on 
the Process menu, click Initialize from ROM.

Select this option if the position of both the cameras and the actor’s 
head in relation to the calibration brim, and other elements (for example, 
the marker set, face poses, etc), are the same in the ROM file as they are 
in the take you are now processing.

❙ To use the data from the calibration brim only, on the Process menu, 
click Initialize from ROM [Brim Only]. 
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Select this option if the position of the cameras in relation to the 
calibration brim is the same in the ROM file as it is in the take you are 
now processing, but other elements have changed.

The data from the first frame of the ROM file is applied to the take from the 
current frame onward.

If Initialize From ROM fails or doesn’t label the majority of the points, see 
Troubleshooting in the Vicon CaraPost Reference Guide.
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Optimize a take

The following topics describe common cleanup tasks involved in optimizing the 
results of automatic tracking. 

The aim of the cleanup and optimization step is to take the initial tracking 
results, use a mixture of manual and automatic tools to correct any errors in the 
data, and to fill any gaps. This will result in clean 3D marker data for the whole 
take.

❙ Tracking errors or swaps

❙ Dropped or missing tracks

❙ Gaps due to lack of blobs

❙ Bad camera contributions

❙ Merged blobs

❙ Single camera tracking

❙ Interpolated gap filling

In addition to cleanup procedures described in the above topics, you may 
occasionally also need to use target tracking. For more information, see Target 
tracking in the Vicon CaraPost Reference Guide.

If required, after you have corrected any errors and filled gaps, you can stabilize 
the results to obtain the best output and/or align the face data in the 3D world. 
For information, see Stabilize a take on page 64 and Align face data in 3D space 
on page 71.
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Tracking errors or swaps
Always begin optimization by correcting any tracking errors or swapped points, 
where the automatic tracking algorithm has mislabeled point(s) on the face or 
brim during the take. The easiest way to detect swapped or mismatched points 
is to create a mesh for the 3D points (for information, see Create a mesh on 
page 43). You can then recognize point tracking errors by playing through the 
tracking results in the 3D view with the mesh overlaid.

Tracking errors and swaps are very time-consuming to fix manually, so if you 
have tracking errors or swaps on more than a few points, it makes sense to undo 
the existing tracking results, and redo the automatic tracking with a more 
appropriate set of automatic tracking parameters (for information, see Tracking 
troubleshooting in the Vicon CaraPost Reference Guide).

However, if you have tracking errors on only a few points, you can delete the bad 
tracking results by hand as described in the following example. 

In this example, the tracker has mislabeled the right corner of the mouth. (Note 
that this error is not present in the supplied ROM take.)

Sometimes the tracking process can track the incorrect points. This is more 
common with very dense marker sets. To fix it, you need to locate the range of 
the swap and remove the data, as described in the following steps.
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To fix tracking errors:

1. To select the frames affected by the swap, go to the first frame of the swap 
and press CTRL+1 (or on the View menu, click Set Active Range Start), then 
go to the last frame or the frame where it swaps back and press CTRL+2 (or 
on the View menu, click Set Active Range End).

2. To remove the bad data across this range, on the Edit menu, click Detach 
Detections [Active Range]. Do this for each camera that has the bad data. 
You can you either select the cameras in the Selection pane or select the 
marker in a single camera view. 

3. Re-track the parts of the take where you have made manual corrections, 
using different tracking parameters if appropriate. 

     Tip
To speed up the tracking, select only the markers that you want to re-track before 
tracking. It’s also often worth running Process menu > Track Forwards [Single 
Frame] on the selected markers, to make sure they don’t swap again.

4. If the points swap again, you can manually correct them by adding the 
correct points. To do this:

a. Go to the frame of the swap and remove the bad data as described 
above. 

b. Either select the correct blob and merge the point (press M), or add a 
point by clicking Edit menu > Edit Target Track. For more information, 
see Target tracking in the Vicon CaraPost Reference Guide. 

5. Re-track using the correct point or the target track that you added. Make 
sure there is no existing data within the range that you are re-tracking. 
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Dropped or missing tracks
A common issue you will come across is that the tracking misses a blob. This can 
happen when a marker gets occluded and then appears again, or for fast moving 
markers on the face, like the eyelids. It’s very easy to fix this though.

In the following example, the tracker has missed the lDimple and rDimple 
markers (note that this error is not present in the supplied ROM take). 

To fix a missing blob:

1. Go to the frame before the tracking drops and select the point, or select it 
in another camera view. 

2. Go forwards a frame to where it drops and select the undetected blob in any 
missing camera views. 

3. Press M to merge the points.

4. Select the merged point and on the Process menu, click either Track 
Forwards [Sequence] or Track Forwards [single frame]. 

     Tip
To speed up tracking, select only the required marker before tracking.
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Gaps due to lack of blobs
Sometimes, tracking fails due to a marker not having enough contrast and thus 
no blob being present. You can improve this by using on-board lights or 
changing the Auto Exposure settings, but you can also manually add Target 
Tracks to help fill any gaps.

In the supplied sample ROM take, the InnerJaw Marker drops out on frame 0254 
in channels 0 and 1.

To fill a gap using target tracks:

1. Select the required point on the frame before it drops out. 

2. To manually add a point, press SHIFT+ E (or on the Edit menu, click Edit 
Target Track). 

     Tip
You can also add a completely new point using this method. For more information, 
see Target tracking in the Vicon CaraPost Reference Guide.  

3. Set the blue inner square to match the size of the marker you are tracking.

4. You can now either track forwards or backwards to try to re-track the gap, 
or fill the gap by clicking Interpolate Gaps on the Process menu.

For more information, see Interpolated gap filling on page 62.
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Bad camera contributions
In some situations, a camera tracks a point that gives bad contributions, for 
example, when a point is on the edge of the face, is too small, or disappears. In 
other cases, points get too close together and the size of the blob jumps, which 
can add noise to the data.

The following example from the supplied ROM take shows the rCheek marker 
in Channel 1 on the edge of the face. 

Points on the edge of the face can cause bad or noisy data, which is visible in 
the 3D Graph View and in the Selected Point view, as shown in the following 
example.

The light blue data represents where a blob has disappeared and the tracker has 
dropped to patch tracking. For more information on patch tracking, see Target 
tracking in the Vicon CaraPost Reference Guide. 

You can fix these issues in different ways, depending on how much of the take 
is affected, as described in the following steps.
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To fix camera contributions that are bad across the whole take:

1. To remove the camera from contributing across the whole take, select the 
marker in the required camera view. In the above example from the supplied 
ROM take, select the rCheek marker in Channel 1.

     Tip
You are recommended only to remove camera contributions on points that are seen 
in three or more camera views.

2. On the Edit menu, click Detach Detections [Active Range]. 

The camera contributions are removed and the point is updated in the 3D 
view. 

If the bad contribution is only across you a certain range, you can select the 
range of the swap and delete the detections, as described in the following steps. 

To fix camera contributions that are bad across a limited range:

1. Go to the first frame of the swap and on the View menu click Set Active 
Range Start (or press CTRL+1), then go to the last frame or the frame where 
it swaps back and on the View menu, click Set Active Range End (or press 
CTRL+2). 

2. To remove the contributions across the range, select the point in the 
camera view and on the Edit menu, click Detach Detections [Active Range] 
(or press CTRL+SHIFT+H).
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Merged blobs
Points that get too close together and merge can often be seen as jumps in the 
data in the 3D view. This is because the centers of the two markers suddenly 
jump as they become one marker. 

In the following example, two blobs have merged into one below the eye. (This 
is not present in the supplied ROM take and is shown as an example only.) 

To fix this issue, you can manually add points in and re-track, as described in the 
following steps.

To fix points that merge:

1. Remove the bad data as described in Bad camera contributions on page 58.

2. Go to the frame before the newly created gap. 

3. In the Tracking Parameters section of the Properties pane, lower the Blob 
Size Difference Threshold to 0.01.

4. Select the two points and on the Process menu, click Track Forwards [Single 
Frame]. 

You should now be able to track the markers as they get close together. 

5. Before continuing, set the Blob Size Difference Threshold back to its default 
value of 0.75.
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Single camera tracking
When possible, you should ensure points can be seen in two or more cameras., 
However, in some situations a marker gets occluded and can only be seen in one 
camera. To handle these situations, Vicon CaraPost has the ability to track 
points using only a single camera.

In the following example from the supplied ROM take, you can see a single 
camera track on the marker rJaw. It is displayed in orange in the Selected Point 
view.

Single camera tracking is used by the automatic tracker when a point is seen 
by only one camera. It is also used when you click Track Forwards [Single 
Frame]. If a point becomes visible again in two cameras, the tracking reverts to 
multi-camera tracking. 

Single camera tracking works automatically when only one camera can see a 
point. You may notice that a 3D trajectory jumps when a second camera picks 
up a point. If this happens, it may be worth using Interpolated Fill as described 
in Interpolated gap filling on page 62.
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Interpolated gap filling
In some situations, a point is missing from all four cameras. For example, markers 
can get hidden under folds of the skin, or lip markers may get hidden during an 
extreme facial pose. Vicon CaraPost can fill these gaps in the data using an 
intelligent interpolated fill. This fill looks at the movement of neighboring points 
and uses an average of their positions. 

For a detailed description of how this function works, see Gap interpolation 
algorithm and Interpolate gaps (Process menu option) in the Vicon CaraPost 
Reference Guide. 

The following example shows the interpolated fill (small red circle) in the four 
camera views. (Note this is not present in the ROM take and is shown as an 
example only.)

To fill gaps:

1. Ensure you have processed your take so that all the available 2D blobs have 
been used. In general it’s best to make use of any existing data before filling 
gaps. 

     Tip
The exception to this rule is if your data is very noisy. In this case, using Interpolate 
Fill might give better results.

2. To fill all gaps across all points in the data, on the Process menu, click 
Interpolate gaps. (If you want to fill only a selected point, select the required 
point first.)

You can see the results of the fill in both the 3D view, 2D camera views, and 
the Selected Point view. In a camera view the fill is represented by a small 
red circle with a line through it. Check the results of the fill in each camera 
view.
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3. If you want to change the type of interpolated fill that is performed, edit the 
settings in the in the Gap-Filling Parameters section of the Properties pane. 

You can choose whether to look forwards or backwards, which will smooth 
out the interpolated fill. You can also specify whether to use single camera 
detections in the interpolated fill.

In the Selected Point pane, an interpolated fill is displayed in red.

Using a mixture of multi camera, single camera, and interpolated fills, along 
with the ability to add manual target tracks to your points you can deal with 
most capture situations. For information on using target tracks, see Target 
tracking in the Vicon CaraPost Reference Guide. 

Before you use the cleaned and gap free ROM take to initialize other files, it’s 
worth saving your scene and exporting your cleaned take. For more information, 
see Export a take on page 73.

To avoid having to repeat all these steps again, you can use the ROM file to 
initialize the other takes, as described in Initialize from a ROM file on page 49.
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Stabilize a take
The stabilization offered by Vicon CaraPost is the process of removing 
unwanted motion from the face points. This unwanted motion can be caused 
by the head rig moving relative to the skull during violent head motions, or by 
the cameras moving relative to the rest of the head rig.

To stabilize a take, you must first have tracked and (if necessary) cleaned the 
relevant data.

CaraPost offers both manual and assisted options for stabilization:

❙ Manual Stabilization, where stabilization relies purely on stabilization 
points that you select, is faster to set up and use, but does not include any 
additional stabilization from CaraPost. The stabilization error (see About 
the stabilization error on page 70) is simply reported by CaraPost at the end 
of the process.

❙ Assisted Stabilization, where CaraPost automatically improves on the 
information that you provide, usually produces the best stabilization. The 
stabilization error is minimized by CaraPost throughout the whole Active 
Range. However, it requires slightly more setup than the manual process 
and can take longer to run, depending on the properties you specify. 

For both options, the first step is to select the stabilization points. For more 
information, see:

❙ Select stabilization points

❙ Manual stabilization

❙ Assisted stabilization

❙ About the stabilization error

❙ Stabilize multiple takes

Tip
To display the results of stabilization, ensure that on the View menu, Toggle Show 
Stabilized is selected. 

When this option is selected, stabilized results are displayed in 3D view. 
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Select stabilization points
The first step for both assisted stabilization and manual stabilization is to select 
stabilization points in a frame where the actor’s face is in a neutral pose. 
CaraPost uses this frame (the base frame) as the 3D reference frame to 
transform the point data from other frames. To stabilize all frames in the Active 
Range (or the whole take if no Active Range is selected), CaraPost uses the 
frame-to-frame correspondence of the stabilization points to define the 3D 
transform that is applied to the point data for each frame.

To select stabilization points: 

1. If necessary, on the timebar, set an Active Range, ensuring that the range 
includes only fully tracked and cleaned data.

2. Scrub through the take and note at least three points that you can use for 
stabilization. To ensure the points provide good stabilization, look for points 
that:

❙ Move as little as possible throughout the Active Range (that is, they are 
unaffected by changes in the actor’s expression).

❙ Are present in every frame throughout the Active Range (that is, that 
any gaps have been filled).

For example, you may find that the inner corners of the eyes or on the upper 
cheeks near the ears are relatively stable, compared with other more mobile 
points.

     Tip
Points on the brim can also contribute to stabilization, but only include them if they 
are fixed relative to the skull coordinate frame. If the brim moves relative to the face 
points during the take (eg slips slightly down the actor’s forehead), do not include 
them. If you want to include brim points, ensure Use Brim Points is selected in the 
Properties pane (for information, see Use Brim Points in the Stabilization 
Parameters section in the Vicon CaraPost Reference Guide.

3. Within the specified active range, scrub to a frame in which the face is in a 
neutral pose and all the stabilization points are clearly visible. This will be 
the base frame, on which stabilization is based. Ensure that the chosen base 
frame is the current frame.
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4. In the View pane, CTRL+click on the three or more points that you noted 
previously.

Selected points turn green.

5. Depending on the type of stabilization you want to perform, for the next 
steps, see Manual stabilization on page 67 or Assisted stabilization on 
page 68.
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Manual stabilization
Manual stabilization takes a minimum of three points that you have selected as 
being relatively unaffected by changes in expression, and then for each frame 
maps those points on the current frame to the same points on the base frame. 

Although a minimum of three points is required, if you can find more stable 
points in the Active Range, select these too, as they will improve the results of 
the stabilization process.

Important
Ensure that any points you select are both as stable (ie static) as possible throughout the 
Active Range and are present in every frame in the Active Range. If you select points that 
do not meet these criteria, stabilization will be impaired.

To perform manual stabilization:

1. Ensure that you have selected at least three gap-free points in the base 
frame, as explained in Select stabilization points on page 65.

2. If you want to select any points on the brim, ensure Use Brim Points is 
selected in the Stabilization Parameters section of the Properties pane.

     Important
Only select brim points if the brim is completely stable. Also note that selecting any 
Stabilization Parameters other than Use Brim Points has no effect on manual 
stabilization.

3. On the Process menu, click Stabilize Data [Manual].

The Log pane displays the progress of the stabilization and the stabilization 
error. The lower the error, the better the stabilization.
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Assisted stabilization 
Normally, assisted stabilization produces better results than manual 
stabilization, as the assisted process examines all the face points, and where 
they are consistent with the original selection, enables them to contribute to 
the final stabilization result and to minimize the stabilization error across the 
whole of the Active Range. 

Tip
Assisted stabilization is normally not as fast as manual stabilization, depending on the 
number of Processing Iterations specified, the Stable Points Percent and whether Use 
Brim Points is selected, which may all require more intensive processing.

To perform assisted stabilization:

1. Select at least three gap-free points from the current frame, as explained 
in Select stabilization points on page 65.

2. In the Properties pane, expand the Stabilization Parameters section and 
make any required changes. For information on the stabilization 
parameters, see the Stabilization Parameters section in the Vicon CaraPost 
Reference Guide. .

3. On the Process menu, click Stabilize Data [Assisted].
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More points are selected and given the weighting specified in the Base 
Frame Weighting and Inter Frame Weighting fields in the Stabilization 
Parameters section of the Properties pane. The stabilization generated 
using these points minimizes the stabilization error across the whole of the 
Active Range. 

In the 3D view, green stabilization points are displayed and in the Log pane, 
the stabilization error is displayed, along with a list of the stabilization points 
used, and the weighting used for each stabilization point.

The following illustration shows a take in which the brim was static 
throughout, so the Use Brim Points property was selected, enabling the 
automatic selection of the brim points as well as the original three selected 
points and other stabilization points added by CaraPost.
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About the stabilization error
The stabilization error is a weighted sum of the following errors:

❙ Base Frame Stabilization Error The root-mean-square of the differences 
between the percentage specified by the Stable Points Percent most stable 
points in each frame and the corresponding points in the base frame 
(calculated across the whole of the Active Range).

❙ Inter Frame Stabilization Error The root-mean-square of the differences 
between the percentage specified by the Stable Points Percent most stable 
points in each frame and the previous frame (calculated across the whole 
of the Active Range).

Stabilize multiple takes
To minimize the chance of ‘jumps’ between takes that are to be used together, 
ensure that for all the takes:

❙ The base frame shows a face with a neutral expression.

❙ The same points are selected for stabilization.

❙ The same points are used for alignment (see Align face data in 3D space on 
page 71),

Note
If you are using the Stabilize Data [Assisted option], different sets of points may be 
automatically selected for use in stabilization in multiple takes. 
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Align face data in 3D space
After you have tracked and (if necessary) cleaned and stabilized the relevant 
take in CaraPost, if required you can align the face data into a coordinate frame 
that you define by selecting 3D face points.

Tip
If you are stabilizing a take that you also want to align, it is preferable to perform 
stabilization before you align the take. This is because if you stabilize after aligning data, 
the markers are returned to their original positions, as stabilization operates on the 
original, raw data, so you will need to repeat the Align Data operation.

To align the face data in 3D space:

1. Ensure no points are currently selected and display a 3D view (on the View 
menu, click New Floating Workspace).

2. As described in Select stabilization points on page 65, select three points 
to define the x, y, and z axes, ensuring you select them in the required order. 
The order in which you select the points affects the alignment: 

❙ The first and second points define the x-axis

❙ The z-axis is defined as the cross product of the x-axis together with the 
normal of the plane of the three points. 

❙ The origin of the coordinate system is the centroid of the three points. 
Vicon Motion Systems January 2015 Page 71 of 84



CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexOptimize
a take
In the 3D view, the order of selection is indicated by a small colored 1, 2, or 
3 to the lower-left of the selected points. 

3. On the Process menu, click Align Data. 
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Export a take

After you have finished processing a take (see Initialize and track a take on 
page 21 and Optimize a take on page 53), you can export the resulting files as 
.c3d or .fbx, ready to use in your animation package.

To export a processed take:

1. On the File menu, click Export C3D or Export FBX, depending on the format 
required by your 3D animation package.

2. Depending on the format you selected, if you have created stabilization and 
alignment data, you can control its export by selecting the relevant option: 

❙ If you select Export C3D, you can clear or select the option Include 
stabilization:
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❙ If you select Export FBX and then in the Save As dialog box, click the 
Options button, you can select or clear the Bake Stabilization option to 
determine how the stabilization data is handled:

❙ If the Bake Stabilization option is cleared (the default), stabilization 
and alignment is output as an animated root node, and if 
stabilization is not required, you can remove it. 

❙ If the Bake Stabilization option is true, the stabilization and 
alignment are pre-baked into the face point data, while the camera 
and the brim point are parented to an animated transform node 
called Stabilization.  

The resulting file is ready for import to your animation package.
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As shown in the following example, you can use Export FBX to transfer your 
Vicon Cara data into 3D packages like Autodesk® Maya®. 

Autodesk screenshot reprinted with the permission of Autodesk, Inc.
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Further resources

You can access further help on using Vicon CaraPostfrom the following 
resources:

❙ Vicon CaraPost videos

❙ Vicon CaraPost sample data

❙ Contact Vicon
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Vicon CaraPost videos
Videos that accompany this guide are available from Vicon Support. The videos 
include the following topics:

❙ Introduction and basic overview 

❙ Blob detection 

❙ Creating and using sticks and labels 

❙ Initialization 

❙ Tracking 

❙ Optimization 

❙ Data export 
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Vicon CaraPost sample data
You can download the sample .pico, .xcp, and .cara files that accompany the 
CaraPost User Guide from the Vicon Support website, in the same location as 
the Vicon CaraPost installer.
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Contact Vicon
If you need more information than that supplied in the documentation or on the 
Vicon Support website, use the following resources to contact Vicon:

Denver, CO

Vicon Denver
7388 S. Revere Parkway Suite 901
Centennial
CO 80112
USA

T:303.799.8686
F:303.799.8690
E: support@vicon.com

Los Angeles, CA

Vicon LA  
5419 McConnell Avenue
Los Angeles
CA 90066
USA

T:303.799.8686
F:303.799.8690
E: support@vicon.com

Oxford, UK

Vicon Oxford
14 Minns Business Park
West Way
Oxford
OX2 0JB
UK

T:+44.1865.261800
F:+44.1865.240527
E: support@vicon.com

Singapore

Vicon Singapore

T:+65 6400 3500
E: support@vicon.com

     
Page 80 of 84 January 2015 Vicon Motion Systems
80

http://www.vicon.com/support/
mailto:support@vicon.com
mailto:support@vicon.com
mailto:support@vicon.com
mailto:support@vicon.com
https://www.facebook.com/Vicon
https://www.facebook.com/Vicon
http://www.twitter.com/vicon
http://www.twitter.com/vicon
http://www.youtube.com/vicon100
http://www.youtube.com/vicon100
http://www.linkedin.com/company/vicon
http://www.linkedin.com/company/vicon


CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexIndex
Index

Symbols
.c3d files, exporting 73
.fbx files, exporting 73
.pico files 7, 23
.xcp files 7, 23

Numerics
3D view

truck, pan and dolly in 31

A
Activating a license 13
Active Range, setting 27

B
Blob detection parameters

about 24
changing 25

Blob detection process 27
Borrowing a license 15

C
Calibration brim

3D view of 29
initializing 29

Calibration files
importing 23

calibration files
importing 7

Camera positions
calculating 29, 30

Camera views
rotating 23
selecting and deselecting 23

Capture files 7
importing 7, 23

Changing the license server 13
Channel views

See Camera views
Checking out licenses 15
Clean up tasks 53
Cleaning up manually 53
Client PC installation 13
Commuter license

check out to network machine 15
overview 15

Contacting Vicon 80
Correspondences

creating 30

D
Deleting detections 28
Detecting blobs 28
Detections

deleting 28
Documentation 4
Dollying in 3D view 31
Dongle licensing

activating 13
requesting license 11

Downloading the installer 10
Vicon Motion Systems January 2015 Page 81 of 84



CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexIndex
E
Exporting takes 73

F
File types

.c3d 73

.fbx files 73
file types

.pico files 7, 23
xcp files 7, 23

H
Headbar

See Calibration brim

I
importing

calibration files 7, 23
Importing capture files 23
Initializing face marker positions 33
Installing CaraLive 10
Installing Vicon software 10

L
Licence server

specifying 13
License activation 13
License file, about 13
License Manager installation 10
License server

locating 13
specifying 13

Licenses, commuter 15
Licensing Vicon CaraLive 11

M
Manual clean-up

about 53
Markers

reconstructing 33
markers

initializing face markers 33
Merging points manually 36
Mouse and keyboard

using in 3D view 31

N
Network license, borrowing 15
Noise, definition 25

O
Orange points 36

P
Panning in 3D view 31
PC requirements 6
PC specification 6

R
Re-projection errors, viewing 31
Requesting a license 11
Rotating camera views 23

S
SafeNet dongle 11
Seed points, merging 33
Selecting

channel views 23
Sentinel License Manager 

installation 10
Specify a license server 13
Stabilizing a take 64
Standalone license

requesting 12
specifying license server 14

Starting Vicon software 22
System

requirements 6
System requirements 6

T
Tracking forwards 47
Page 82 of 84 January 2015 Vicon Motion Systems
84



CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexIndex
Trucking in 3D view 31

U
Upside-down camera views 23

V
Vicon Automated Unified Licensing 

Tool (VAULT) 11
Vicon contact details 80

W
Windows version 6

Y
Yellow projections 36

Z
Zooming in 3D view 31
Vicon Motion Systems January 2015 Page 83 of 84



CaraPost
User
Guide

About this 
guide

System
requirements

Install & 
license

Initialize
& track

Optimize
a take

Export
a take

Further 
resources

IndexIndex
Page 84 of 84 January 2015 Vicon Motion Systems
84


	Vicon CaraPost User Guide
	Contents
	About the Vicon CaraPost User Guide
	About Vicon Cara documentation

	Prepare to use Vicon CaraPost
	Vicon CaraPost requirements
	About Vicon CaraLive output files

	Install and license Vicon CaraPost
	Install Vicon software
	License Vicon CaraPost
	Request a license
	Activate a license
	Set the license server
	Move and revoke licenses
	Revoke a license
	View information about license servers


	Initialize and track a take
	Start Vicon CaraPost
	Import capture files
	Set blob parameters
	Preview and adjust blob parameters

	Detect blobs
	Initialize the calibration brim
	Initialize face marker positions
	Manually connect data
	Label face markers
	Create a mesh
	Track the rest of the take
	Save the completed take
	Initialize from a ROM file

	Optimize a take
	Tracking errors or swaps
	Dropped or missing tracks
	Gaps due to lack of blobs
	Bad camera contributions
	Merged blobs
	Single camera tracking
	Interpolated gap filling
	Stabilize a take
	Align face data in 3D space

	Export a take
	Further resources
	Vicon CaraPost videos
	Vicon CaraPost sample data
	Contact Vicon

	Index


